Qashqai 2019 problem with 3 system faults (radar, lane assist and sign recognition) - FIXED

ICE, Equipment, Options
Post Reply
arczi19
Posts: 6
Joined: Fri Jun 07, 2024 4:42 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by arczi19 »

Hello,
In the last few weeks I've been having problems with my 2019 Qashqai displaying 3 system faults (radar, lane assist and sign recognition) typically 2-3 minutes after the car has been started. I've looked through the forum and whilst I have seen some other people reporting this exact problem, no one seemed to have any concrete solutions - I was hoping perhaps someone would have more insight now. I've replaced the battery hoping that would fix the problem, but unfortunately not.
Strangely enough those faults dont always appear, in the last 2 weeks or so maybe half of my journeys were without the faults.

WsfQC1HgRnu5kvL4uKGs_A.jpeg

Last edited by arczi19 on Wed Jul 10, 2024 11:13 am, edited 1 time in total.

andy2019
Posts: 2035
Joined: Sat Oct 26, 2019 8:47 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by andy2019 »

First thing to get checked out is your battery
arczi19
Posts: 6
Joined: Fri Jun 07, 2024 4:42 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by arczi19 »

andy2019 wrote: Fri Jun 07, 2024 5:12 pm First thing to get checked out is your battery
Unfortunately it’s not the battery, as I have just replaced it and the problem still occurs with the new battery (but perhaps less frequently?)
andy2019
Posts: 2035
Joined: Sat Oct 26, 2019 8:47 pm
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by andy2019 »

have you had a code reader on car to see if any errors were stored ?
Pandjh
Posts: 821
Joined: Sat Feb 04, 2017 11:34 am
Location: South-East England
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by Pandjh »

Screenshot_20240421_183126_Photos.jpg

Take a look at your rear drivers side ABS cable for corrosion, it's possible it's on its last legs. When mine failed and I had all the lights etc I could clear them all just by holding the wires together.
2019 1.3 DiG-T 160 Tekna, black (J11b)
prev 2015 1.2 DiG-T n-tec+, black (J11)
prev 2009 1.5 dCi Acenta, black (J10)
arczi19
Posts: 6
Joined: Fri Jun 07, 2024 4:42 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by arczi19 »

Pandjh wrote: Sat Jun 08, 2024 5:05 am Screenshot_20240421_183126_Photos.jpgTake a look at your rear drivers side ABS cable for corrosion, it's possible it's on its last legs. When mine failed and I had all the lights etc I could clear them all just by holding the wires together.
I had a look and that cable looks fine on my car, no sign of any damage or corrosion.
arczi19
Posts: 6
Joined: Fri Jun 07, 2024 4:42 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by arczi19 »

andy2019 wrote: Fri Jun 07, 2024 10:28 pm have you had a code reader on car to see if any errors were stored ?
Getting a reader tomorrow and will check if there is anything.
arczi19
Posts: 6
Joined: Fri Jun 07, 2024 4:42 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by arczi19 »

Hmm I got a code reader and it said no error codes found. Also since Friday I've done 6x 5-20 minute long trips and havent seen the system errors pop up. Very odd.
arczi19
Posts: 6
Joined: Fri Jun 07, 2024 4:42 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by arczi19 »

I think I've fixed this problem myself: I've dismantled the front camera (I was inspired by a post by Gorifinland in a different thread) by removing the plastic cover, then 4 screws, unplugging the ribbon connecting lens module from the motherboard and finally unplugging the power/data cable. I left it unplugged for few minutes, then put it together by plugging the ribbon connecting lens module first, then power/data cable, the 4 screws and plastic cover (I think the order of connecting cables matters, as you don't want to be plugging power into the motherboard if the lens module is not connected) - no system faults on the dashboard ever since! Its been about a week since I've done this and I've been using the car daily ever since.
Post Reply