Fluctuations in power whilst driving

General Chat about the Mk1 QashQai
Post Reply
pethedges
Posts: 1
Joined: Fri Jan 07, 2022 10:16 pm
Qashqai Model: Mk.1 Qashqai - J10 (2006–2013)

Post by pethedges » Wed May 11, 2022 7:00 pm

So…got my 1.5 dci qashqai last August. It had just had the turbo sensor replaced and injector number 4.
Just before Xmas injector 1 went whilst I was on the motorway ( red engine light and rough engine). Got it replaced…and driving from the garage it was like a kangaroo hopping. So went straight back to garage. They took it for a test drive and it was fine for them. I then drove it home…all ok. Until
Last weekend….when the same thing happened again. Red engine light…loss of power…. But within 1/4 mile it cleared itself and light went off.

Took to local garage and nothing showed up on the diagnostic….apart from
Previous codes that related to turbo sensor and injector 1.
However every now and then I feel slight hesitation on and off when am driving along. Any thoughts please? I have a couple of really long journeys coming up!! Thanks so much in advance!

User avatar
gloucester
Posts: 4493
Joined: Sun Apr 03, 2016 7:04 am
Location: Gloucestershire, England
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by gloucester » Fri May 13, 2022 9:39 am

Welcome to this forum.

Haven't a clue but that sort of thing sounds like a loose or corroded connection or a fracturing wire somewhere.
(2015 Nissan Qashqai Tekna DIG-T 1.2 sold 15/6/18) ~ 2018 Suzuki Ignis SZ5 - 2018 Yamaha MT-07

Post Reply

  • You may also be interested in...
    Replies
    Views
    Last post