O2 sensors

General Chat about the Mk1 QashQai
Post Reply
sam1
Posts: 3
Joined: Mon Nov 30, 2020 9:17 am
Qashqai Model: Mk.1 Qashqai - J10 (2006–2013)

Post by sam1 » Mon Nov 30, 2020 9:22 am

Hi there, new to the forum. Always find these helpful! Hope everyone is well.
I have some work to do on the mother in laws 2007 QQ next week. Basic service & o2 sensors.
Its showing -67000 miles since service due - with this number of miles will I be able to reset it myself or will it have to go to the dealer?!
It also has error codes of P0139 P1147 P1706.
Am I right in thinking the first two are related to the o2 sensors - and does anyone know if the o2 sensors are both the same in part number? I prefer to replace like for like but always consider bosch as a first choice.
I cleared the codes a few weeks ago but EML came back on so now to do the work.
Thanks in advance!

Screenshot_20201130-09213.jpg

Screenshot_20201030-134111_Torque.jpg


User avatar
gloucester
Posts: 3771
Joined: Sun Apr 03, 2016 7:04 am
Location: Gloucestershire, England
Qashqai Model: Mk.2 Qashqai - J11 (2013–2017)

Post by gloucester » Mon Nov 30, 2020 9:38 am

Welcome to this forum

Haven't a clue I'm afraid but hopefully calnorth will be along shortly!
(2015 Nissan Qashqai Tekna DIG-T 1.2 sold 15/6/18) ~ 2018 Suzuki Ignis SZ5 - 2018 Yamaha MT-07

User avatar
calnorth
Posts: 2428
Joined: Mon Feb 11, 2019 2:01 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by calnorth » Mon Nov 30, 2020 10:57 am

DTC info below from Nissan diagnostics:

The sensors appear to be identical, probably the Universal pick. I've used an after market 02 sensor on a BMW. Jap NGK and not a problem. Since Bosch are into most anything vehicle I suspect they would be ok and likely OEM. BMW scheduled servicing required 02 sensor change at about 70k miles. Don't think we know Nissans approach but can't be much different?

It might be necessary to visit Nissan to perform certain test procedures after O2 change. The initial test is to check 02 sensor output voltage without CONSULT-III (Nissan Test Tool):
Start engine and warm it up to the normal operating temperature.
Turn ignition switch OFF and wait at least 10 seconds.
Start engine and keep the engine speed between 3,500 and 4,000 rpm for at least 1 minute under no load.
Let engine idle for 1 minute.
Check the voltage between ECM harness connector and ground under the following condition....revving engine to 4000 rpm. Looking for a small voltage change that proves sensor working...."A change of voltage should be more than 0.12 V for 1 second during this procedure".

In the case of my BMW it was a case of driving the car for about 20 mins at similar revs above, so the ECU learnt the behaviour of the new 02 sensor. That begins as lumpy running until the ECU regains correct control. Nissan procedure might be somewhat different and require their CONSULT tool where things don't go smoothly?

As regards EML...I think it should self clear if an error is not detected after 3 separate engine starts and runs. Try your tool again. If fail its off to Nissan I think.

P0139 HO2S2
Description
INFOID:0000000001089356
The heated oxygen sensor 2, after three way catalyst (manifold), monitors the oxygen level in the exhaust gas on each bank.
Even if switching characteristics of the heated oxygen sensor 1 are shifted, the air-fuel ratio is controlled to stoichiometric, by the signal
from the heated oxygen sensor 2. This sensor is made of ceramic zirconia. The zirconia generates voltage from approximately 1V in richer conditions to 0V in leaner conditions. Under normal conditions the heated oxygen sensor 2 is not used for engine control operation.

P1147 HO2S2 - Same description as P0139

P1706 Park/neutral position (PNP) switch - Not sure about this for UK as diagnostics document is US
Mk2 Qashqai Facelift - J11b (2017–present)
1.6 Dig-T N-Connecta

sam1
Posts: 3
Joined: Mon Nov 30, 2020 9:17 am
Qashqai Model: Mk.1 Qashqai - J10 (2006–2013)

Post by sam1 » Wed Dec 09, 2020 11:48 am

thanks for you reply calnorth.

sam1
Posts: 3
Joined: Mon Nov 30, 2020 9:17 am
Qashqai Model: Mk.1 Qashqai - J10 (2006–2013)

Post by sam1 » Fri Feb 12, 2021 12:28 pm

I changed both sensors using the ones from the screenshot and believe this has fixed the issue.
However the P1706 code remains which I believe may be a neutral position switch.

User avatar
calnorth
Posts: 2428
Joined: Mon Feb 11, 2019 2:01 pm
Qashqai Model: Mk.2 Qashqai Facelift - J11b (2017–2021)

Post by calnorth » Fri Feb 12, 2021 12:39 pm

sam1 wrote:
Fri Feb 12, 2021 12:28 pm
I changed both sensors using the ones from the screenshot and believe this has fixed the issue.
However the P1706 code remains which I believe may be a neutral position switch.
Yep...well done.. :)

...................................

Screenshot 20.png

Mk2 Qashqai Facelift - J11b (2017–present)
1.6 Dig-T N-Connecta

Post Reply

  • You may also be interested in...
    Replies
    Views
    Last post