Page 1 of 1

Heater Blower fans not working.

Posted: Sun Nov 12, 2023 12:34 pm
by Glannigan
Hey All

Over the last couple of weeks my blowers would take a few minutes to come on but after a few minutes of the engine running they would kick in. Now today the are completely dead and won't come on with any speed or setting...no noise or air coming at all.

I've checked and replaced the fuses and it's still the same. Before I order parts would this be the heater resistor or the blower motor?

2013 1.5 dci Tek.

Re: Heater Blower fans not working.

Posted: Sun Nov 12, 2023 4:52 pm
by Squashy2
My previous J10 never had any issues with the climate control, however the J11 has had no end. If by chance the system is a similar design then I'd hazard a guess that your resistor is either on its way out or worse.

Re: Heater Blower fans not working.

Posted: Sun Nov 12, 2023 7:26 pm
by Glannigan
Both parts were relatively cheap so i ordered both to cover all bases. After watching a couple of vids on YouTube, both look fairly easy to swap out on the J10. I'm crap at mechanics but a dab hand with a screwdriver lol. I'll post my results once the parts arrive in a day or 2 incase anyone else has similar issues.

Re: Heater Blower fans not working.

Posted: Mon Nov 20, 2023 8:15 am
by Glannigan
So changed out both the heater blower motor and resister with brand new parts but still no joy. I've now discovered my radiator fan isn't spinning at all. Does anyone have any clue what the issue can be? I'll try changing the 50A multi fuse and see if it helps but I'm thinking I'll need to bite the bullet and put this in to a garage.

Re: Heater Blower fans not working.

Posted: Mon Nov 20, 2023 8:59 am
by Squashy2
Does your car engine temperature run normally i.e cool? Hopefully changing the fuse/relay may cure it, if not and your temps are good you may have a faulty thermostat (stuck open) which will cause the coolant to constantly flow thus not allowing the radiator fan to start spinning.
Could also be broken wiring.
Have you also checked the radiator/coolant?
Could be any of the above but if you're relatively proficient with the oily bits you could probably cure it without the expense of a garage.

Re: Heater Blower fans not working.

Posted: Mon Nov 20, 2023 8:06 pm
by Glannigan
Radiator coolant level is fine and temp gauge sits around the halfway mark mate...its driving me up the wall though that no fans are working at all. At this rate I'd have built a new car by the time I find this fault haha

Re: Heater Blower fans not working.

Posted: Fri Nov 24, 2023 3:16 pm
by Glannigan
Finally found the issue, it was the heater blower relay thats located in the drivers side fuse panel that was faulty.

Re: Heater Blower fans not working.

Posted: Thu Dec 14, 2023 6:14 pm
by Adrianbutler1982
Hi there

I think I have the same issue, I’ve removed the relay but cannot find one for sale anywhere. Where did you get yours from?

Adrian

Re: Heater Blower fans not working.

Posted: Thu Dec 14, 2023 6:41 pm
by andy2019
https://www.ebay.co.uk/itm/364522369008
not sure if this is what you need or not